Troubleshooting Video Widget

My video isn't working

The Video widget simply embeds the video on the site. If the video is not working, it may be because the video has been removed or its share settings prevent it from being played. Make sure the video has the right sharing settings.

The wrong thumbnail is showing

The thumbnail image is pulled from the YouTube, Vimeo, or DailyMotion settings. Try using the embed code that the video host provides and place that in using the HTML widget to see if the issue persists.

How do I choose the streaming quality?

The streaming quality depends on the limits that are available on YouTube, Vimeo, or DailyMotion. The user will be able to adjust the quality as they see fit using the settings icon.

Video loads too slow

Video load speed depends on the connection speed of the viewer.

Why is my video not autoplaying on the live published site?

The autoplay feature only works if the audio is muted. This is due to specific browser restrictions and is not exclusive to Duda sites. Read Chrome's documentation about autoplay (Firefox and Safari have similar restrictions as well).

To mute the audio and enable autoplay, click the video to open the Content and Design menu. On the Design tab, click Customize Video then switch the Mute Video toggle to the off position.

Was this article helpful?
0 out of 0 found this helpful
×

Please Log in as a Pro

Priority Phone Support is available exclusively to Pros. Log in to your Pro account now to see our international support numbers.

Log In
Not a Pro? Purchase a Pro plan!